Bought the game, but unable to install - Microsoft Store not working at all

  • First of all, my thanks to those who decided it was a good idea to accept my card details before revealing all this nonsense I have to go through before even attempting to install.

    Bought the game, need Microsoft store to install, Microsoft store closes immediately on opening. Nothing works, please help.

    Some common google solutions which have not worked...
    -Windows + R + WSReset doesn't work
    -Making sure I have the correct time zone doesn't work (How is this even a solution?)
    -Creating a new user profile doesn't work
    -SFC and DISM commands don't work
    -Deleting the cache folder contents doesn't work

  • 4
  • @farmer-chegu 33/5000
    There are several solutions to try., I can not post links, but you can place it in google.
    Re-register the Windows Store, Create New Local Cache Folder, Run Official Windows Store App troubleshooter, Disable Proxy Connection.

  • @farmer-chegu my brother had this issue. Make sure your windows update is up to date. He had the same issue where it wasn't downloading and once he did a windows update it worked. Good luck!

  • @farmer-chegu said

    -Making sure I have the correct time zone doesn't work (How is this even a solution?)

    Oh, you are supposed to check that whilst holding your left foot behind you right ear.
    I only came across that one by trial and error. lol

    Sorry to hear of your dilemma, I had heaps of problems with installing it on my son's PC which is an identical twin to my PC both with brand new installations of Win 10 on brand new HDDs.

    His installation of Win 10 kept corrupting the Microsoft Store user file. I had to keep trying everything repeatedly before it finally came good.

    Here's what I tried. Remember it may not work the first time.

    These are some troubleshooting tips below that may help you get into the game should you be one of the affected players.

    Fix #1
    Login to Windows 10 with a local Microsoft Account. This fixes majority of cases reported.

    Fix #2
    Open the Windows 10 Store, then in the top right corner click on the profile picture.
    If you have multiple accounts signed in, sign out all of them but leave the email account linked to the game’s purchase signed in.
    Next, in the Windows 10 Store download any free app at all.
    Then try playing Sea of Thieves again through the Windows 10 Store “Library” page.

    Fix #3
    Go to the below link and save / run the tool. Follow the on screen instructions to troubleshoot / fix your issue.

    Press Windows + R
    Type Powershell and hit enter
    Copy and paste the following into the powershell window and press enter

    Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

    If your problem persists please create a support ticket for further assistance.


    I hope that helps, mate.
    It wasn't until after I performed the Poweshell tip the second time that it started to work.
    Remember to reboot between each attempt.

2 out of 4