[PC] How to change microphone input?

  • So I have multiply audio inputs on my P and not matter what I change my input to on windows, SoT always uses one particular microphone. I even selected and input on windows that didn't even have an input, yet when I went in game, It was using my headset again.

    How do I change my mic input for this game?

  • 9
    Posts
    69.3k
    Views
  • Try changing it in the game bar settings (Win+G to bring this up, and go to settings).

    Also, disable any inputs you are not using in the Windows audio properties recording tab.

  • @realstyli

    Thanks, I have tried Win+G but it never worked. However I will try again.

  • @twitch-xk90

    Nah didn't work at all. I did manage to get it to stop using my headset but it refuses to use my virtual audio cable.

  • Yeah, the audio input for SoT is very frustrating at times, and it might be down to how Windows manages that sort of thing for UWP apps. I wish they would just make it simple and allow us to select the input from within the game.

  • @twitch-xk90 If you go to the advanced sound settings, you can change the input device for any open app. This can be finicky, though.

    Which virtual audio cable are you using and have you made sure the sample rates are all the same?

  • While SoT is running go to your windows sound settings, and on the top there are the default input/output, but don't choose it there, get the list of apps, then change SoT's input to what you want.

    Then quit SoT and launch it again and it should work.

  • Got it sorted, the trick was to go to my audio devices and "Right click, Set to default" on the Mic I wanted, simply changing it in the Xbox App or anywhere to use a certain device didnt work.

  • If audio device preferences keep resetting/changing (often used to happen after Windows Updates for me) look for the program Ear Trumpet on the Windows Store.

    Appears to have sorted it for me (at least so far...)

9
Posts
69.3k
Views
1 out of 9