Game won't load

  • 0

    I'm playing free through my boyfriend's game code but when I try to load into the game I get stuck with the loading screen. It doesn't freeze, the images change, the text changes and the wheel keeps spinning but I don't make any progress or actually get into the game. I had no issues running it before during the beta and I know it's not my PC.

    Any tips would be greatly appreciated.

    Thanks,
    Ellie

  • 1

    So it won't load you into the actual server?

    Might want to try to restart the game and your pc just to be sure. If that doesn't work I'd recommend you take a peek at the support website for SOT. They might have a solution for your problem. https://support.seaofthieves.com/hc/en-gb

    Cheers,

    Kevin - cheeky pirate

  • 0

    @evilkevin22

    Thanks for your reply!
    That's correct - the server won't load so I'm just stuck on the loading screen. I've restarted my game several times and restarted my PC once now but still nothing.

    I've had a look at the support page but I can't seem to find any solutions to my specific issue.

    Thanks,
    Ellie

  • 0

    UPDATE:

    I can hear the people who are in the server I'm joining through voice chat.

  • 1

    I have previously encountered what you are describing, unfortunately I don't have a clear fix for you. The situation I first encountered it in was when joining a crew fighting the skeleton fleets, it effectively had me in the game but I was not visible, but could hear everything going on. It eventually loaded me into the game but it wasn't until after the skeleton fleet had been defeated - good news was that I earned one of the achievements while stuck in the black loading screen.

    I have encountered once or twice otherwise but haven't had a solution, other than once it seemed to fix when I swapped internet connections (from ADSL to 4G, or vice versa). It seems to only occur when joining a crew, and when something is going on in the game.

    All I can recommend is: restarting computer, restarting router, and if both of those don'e work just let it sit there and see if it eventually connects. Sorry I don't have a proper solution.

  • 1

    I had a similar thing a while back and was confused as all heck.....until (eventually...) I realised I still had PhotoShop open, which was gobbling up a chunk of my PC's brain...

    @Queen-Eleanor-I other than making sure that you don't have any other resource hungry programs open at the same time.....have you checked that Sea of Thieves and the Xbox app have internet access permissions from any Anti Virus/Firewall you may have? (I went through a period using Panda AV and needed to allow Sea of Thieves permission after every update!!)

    Also check they are allowed to run as background apps. (Settings-- Privacy-- Background Apps)

    Make doubly sure that only one Microsoft Account is signed into the PC you are trying to play on (signing another one in doesn't necessarily mean the other is signed out! (another thing that had me stuck for a while)

    Other than that...make sure Windows and your GPU drivers are up to date.

    These may not help but are always worth a try if nothing else is working.

    If you are still having issues after trying, your best bet would be to contact Support