If you're on PC and still can't get your mic to work, try this.

  • 0

    Go to Settings, Sound, Manage Sound Devices, and Scroll down to your input devices, and disable all of them Except for the one you're wanting to use. I'm guessing the Game just picks one from the list without even thinking, and since there's no in game option to change it, really the only way to change which mic it uses is to disable the other ones. If you need those sound inputs, you can always scroll back down and Re-Enable them

  • 0

    I found my mic had a second 'default' communication device that wasn't my mic.

    As soon as I made my mic (which had the green default tick) the default comms device I got in game voice comms perfectly fine.