Error "Couldn't start a DCOM-Server", game doesn't start

  • 0

    Hello thieves of the sea,

    I know there is currently a thread that also deals with client startup issues, but I believe my problem is different.

    Problem:
    Upon launching Sea of Thieves, the SoT logo shows up for a few seconds (not even the Rare logo), then the window closes again. If I start it again afterwards, absolutely nothing happens. The SoT logo shows up again when launching after a computer restart. The issue first arised yesterday, when I wanted to launch the game after updating. It worked perfectly fine a few weeks ago.

    I don't know if it's related, but the event log spits out the following:

    "Ein DCOM-Server konnte nicht gestartet werden: Microsoft.SeaofThieves_2.92.2201.2_x64__8wekyb3d8bbwe!AthenaClientShipping als Nicht verfügbar/Nicht verfügbar. Fehler:
    "2147942405"
    Aufgetreten beim Start dieses Befehls:
    "C:\Program Files\WindowsApps\Microsoft.SeaofThieves_2.92.2201.2_x64__8wekyb3d8bbwe\Athena\Binaries\UWP64\SoTGame.exe" -ServerName:AthenaClientShipping.AppX1tppsmwxvf2km3jd8xq57zc8r6c65hfj.mca"

    which roughly translates to:

    "A DCOM-Server couldn't be started: Microsoft.SeaofThieves_2.92.2201.2_x64__8wekyb3d8bbwe!AthenaClientShipping as not available/not available. Error:
    "2147942405"
    Occurred when executing command:
    "C:\Program Files\WindowsApps\Microsoft.SeaofThieves_2.92.2201.2_x64__8wekyb3d8bbwe\Athena\Binaries\UWP64\SoTGame.exe" -ServerName:AthenaClientShipping.AppX1tppsmwxvf2km3jd8xq57zc8r6c65hfj.mca"

    Things I did already:

    • Updated Windows
    • wsreset.exe
    • app reset of Sea of Thieves
    • app reset of Xbox Companion
    • a lot of computer reboots
    • in services.msc, set Plug & Play to automatic start in properties
    • uninstalled several programs/apps I installed recently, one of them the only VPN client I had installed
    • change region and language to USA and English (USA)
    • downloaded a random free app from the microsoft store
    • started Sea of Thieves from Desktop, Microsoft Store, Xbox Companion
    • unticked/ticked automatic timezone recognition
    • sync'ed time anew
    • updated NVIDIA graphics driver
    • disabled NVIDIA Geforce overlay
    • disabled "Gaming" mode
    • disabled game bar to record videos, screenshots etc
    • disabled "record in the background" option
    • executed some powershell commands I can't recall
    • no such program as a Sonic Radar or Studio installed on my computer
      I probably tried more but I'm working on it since yesteday, so I can't recall every single measure. I don't know if the error code I posted above is connected to my problem, but I thought it might help identifying the issue.

    If you have an idea how to fix, please take a moment and tell me. I'd like to play again ASAP :D

  • 1

    Hello, I just wanted to report back as I got my game to work again. I think it is not related to the DCOM error, but anyway:

    My game is usually installed on disk D. It is recommended to install on C, so I wanted to try and move it from D to C using "apps & features". I noticed the install path is already on C, which is strange, because my game files are, in fact, on disc D. I could be wrong, but I assume the latest update changed the install path to a place where there are no game files.

    1. Press Windows key
    2. Type in the search bar "Apps & Features" (without the ")
    3. Search the list for Sea of Thieves
    4. Click Sea of Thieves in the list
    5. The left button should be "transfer", "move", or something similar (my language is set to German)
    6. Move the game to the disc where your game files are located - Usually, that's where the folder "Windows Apps" is located

    I hope I could help someone in the future, stumbling upon the same problem.

  • 0

    This solution worked for a similar issue I was having with a similar game. I was getting a DCOM error for Horizon 4 (also purchased from Microsoft Store) and I have my software installed on C: but all my user data (including AppData) is on a D: drive. I also went through that whole list of thing and none of those worked. However, performing the Move and moving the game from C: to D: resolved my issue. Don't think I'd ever come up with that solution on my own so I thought I'd make a note of it here for anyone else running into this in the future.

    thanks!