Hunter's Cry

  • Is anyone else having trouble getting through the portal to the Sea of the Damned? The game kept me waiting for about five minutes before it booted me back out into the Sea of Thieves.

    Also, do we really have to work together with other crews again in order to get the memento?

    Edit: I got it on my second try. I was lucky in the fact that there were two other friendly crews on the other side. We all tackled the Adventure together and I was done within an hour or so. I will say though, I can see a lot of other people having difficulty finishing this Adventure; Player vs. Player encounters are one thing, but I was having trouble positioning the lighthouse in the right locations.

  • 38
  • @lucky11 It's not required, you just get put into a Sea of the Damned instance with other crews (potentially). Whether you work together or not is up to you and whoever you get matched with.

  • @d3adst1ck
    Thanks! I got worried there for a sec. (I really want that painting of Merrick)

  • @lucky11 i also am stuck and cant progress thru i just tried twice 🤦‍♂️ but im sure it should be fixed soon!! Hopefully

  • @hornet-hill-19 had no issues...maybe just bad luck and it tried to put you onto a full server or something like that...maybe wait a bit and try again

  • @schwammlgott thats wat i was thinkin i think ill try again in an hour or so

  • Got through in the second attempt and was met by a brig of idiots intent on disrupting the adventure. Just be persistent and you will get it done. Doesn’t matter if your ship sinks. It will respawn, so just let the trolls do whatever they want to it

  • @pabio-escobar
    Thanks! I think the game glitched on my first go-around.

  • @hornet-hill-19
    I logged out and loaded a new server and it worked for me. Maybe try that?

  • @lucky11 everything is now ok im happy to report. Cheers

  • @hornet-hill-19
    Cool! I'm glad you were able to do it!

  • Did it first try, only encountering a bit of confusion with the lighthouse beam targets. The crews were cooperative.

  • @blazebeard2313
    I had the same thing happen to me. My problem with the lighthouse is that I couldn't see where you had to point the light. (the beacons you had to ignite were blending into the dark shadows of the tavern. I couldn't really make out anything even with my telescope)

  • Tried twice to go through the portal - both times respawned with the ship at an outpost. I thought there was an insider program or something to avoid such things.

  • I got through once but the game bugged out and I got stuck in the Sea of the Damned unable to leave. Currently trying to go back but the game keeps booting me out before I make it there.

  • It worked for me on the second try, however after dealing with a gally spawn camping everybody and actually completing the Sea of The Damned part, it send me back into the Sea of The Damned making me redo it all over again.

  • "Thanks" to the adventure not working I went outside to get some fresh air when sudden gust of wind shattered the glass in my door. Already dislike this adventure before even getting inside.

  • Okay, so first of all can you not toy with my emotions and make me hunters CRY.

    hate you.

    Second off... park your boat where the pier appears. YMMV...but holy malarkey I've seen some good stuff. I got one guy catching HUGE air. It won't upload to let me share tho.

    The forced cooperation worked well. Even tho I'm not a fan. I did have a TDM person on my second run and it didn't end correctly either.

    I have the momentos and am going for a 3rd run with my Troll on his new ship. Wish me luck 😆

  • All set with a friend to excitedly do the Adventure, and we got sent back to another Ourpost? What kind of Adventure is this?! The Pirate Lord says the portal is open, and yet now there is no portal!

    ...I hate getting Rared. 😒

  • @galactic-geek
    Same happened to us. Cancel the adventure on your table and restart it. That worked for us.

  • @galactic-geek
    That happened to me the first time around too, it was weird. I would log out and join another server. I did that and the second time around I was able to complete the adventure.

    Just a warning, I had trouble lighting the beacons and platforms with the lighthouses. They are hard to spot and the lighthouse controls are a little finicky.

  • On our first try we got only empty sea with a green glowing thing far far away. We cancelled it and got the Lighthouse checked off... Pirate Lord appeared and said something and then we were on our way back to the regular server.

    Second try we got in as intended and there was a brig fighting another sloop and already a galleon on one of the docks. We sunk the brig (we think the crew of that one manned the cannons on the Galleon, but after some exchange of fire we thought they gave up) and we completed the Adventure with some interference at the lighthouses.

  • Don't park too close to where the pier appears 🤣

  • @pithyrumble

    Hahaha. That’s amazing. Love that you had to have a little look up too just to check how they were getting on

  • @testakleze said in Hunter's Cry:

    Same happened to us. Cancel the adventure on your table and restart it. That worked for us.

    There was nothing on the table to cancel. I checked.

  • @pabio-escobar said in Hunter's Cry:


    Hahaha. That’s amazing. Love that you had to have a little look up too just to check how they were getting on

    Witnessing the shenanigans is as much fun as contributing. If you can't do it, document it!

  • Me and my friends tried to get through the second portal 3 times before we finally got into one, but it was all finished by the time we got there and people started shooting at each others' ships while the finishing dialogue was going.

    I am going on a 2 week vacation in the morning, so I will miss out :(

    Not too fussed about it though, I'm not really interested in the painting.

    Good luick to y'all and happy sailing. 😅

  • @pithyrumble said in Hunter's Cry:

    I got one guy catching HUGE air. It won't upload to let me share tho.

    I had the same thing, parked my sloop, then figured out i need to use the lighthouse to progress further. Got the beacon lit and just saw my own sloop just flying past the lighthouse. That was great!

  • @galactic-geek
    Weird. Guess we had two different bugs that just seemed the same. Were you at a different outpost? We showed up at the same one we left. Maybe even the same server, but I don't really know. Once we canceled and went back to Larina, everything worked fine. Except for a brig killing everyone at the event.

  • @super87ghost

  • @pithyrumble Already saw that clip ;-)
    It's a bit simular yes, although my ship went a lil less high.

  • this is probably the worst experience i've had in SOT. first 3 instances i join i gets idiots TDMing and then the 4th instance i join i didn't get to do anything as someone who knew exactly what to do basically did it all before i got to any of the objectives. i want, no i expect to actually play the game not be a bystander.

  • Not working, was so hyped but can't do it

  • Is there any reason this just doesn’t work? Got in on my first try where there were 2 galleons that just boarded me and killed me until time ran out. Now the two of us go through the portal and get sent back to the island.

1 out of 38